Report Design
 Crystal Reports Forum : Crystal Reports 9 through 2016 : Report Design
Message Icon Topic: formula not matching Post Reply Post New Topic
Author Message
Kitty1
Senior Member
Senior Member
Avatar

Joined: 14 Apr 2010
Online Status: Offline
Posts: 157
Quote Kitty1 Replybullet Topic: formula not matching
    Posted: 04 Nov 2019 at 8:11am
Hi,

I have a report which brings in shared variables to main report from subreport. i am doing a simple calculation:

{#RTotalEssl}+{@Shared Essl}-{@shared essl deletes}

where #RTotalEssl value = 0
and @Shared Essl = -2197.70
and @shared essl deletes = 0

I am getting a value of zero. Yet when i bring each number into the report to see what the values are, they are as listed above. total should be -2197.70 I am going crazy with this one.

It should be working and it should not be that difficult!

IP IP Logged
lockwelle
Moderator
Moderator


Joined: 21 Dec 2007
Online Status: Offline
Posts: 4285
Quote lockwelle Replybullet Posted: 08 Nov 2019 at 10:36am
I always break a formula that is not working into pieces...like one for the running total and one for the shared variable. See if they are working as expected.

HTH
IP IP Logged
Kitty1
Senior Member
Senior Member
Avatar

Joined: 14 Apr 2010
Online Status: Offline
Posts: 157
Quote Kitty1 Replybullet Posted: 08 Nov 2019 at 10:40am
Hi! Thanks for your reply!   The issue has been resolved. I was adding a negative to a zero and didn't realize that adding a negative to a null or zero, it is still null.   So i learned something Have a great weekend!   
IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.047 seconds.