Writing Code
 Crystal Reports Forum : Crystal Reports for Visual Studio 2005-2015 : Writing Code
Message Icon Topic: .net web page crystalreportviewer Post Reply Post New Topic
Author Message
Matt
Newbie
Newbie
Avatar

Joined: 04 Jun 2008
Location: United Kingdom
Online Status: Offline
Posts: 19
Quote Matt Replybullet Topic: .net web page crystalreportviewer
    Posted: 04 Jun 2008 at 7:37am

This is driving me even madder!

This is my first attempt at using the crystalreportviwer on a wb page.
 
I'm using visual studio 2002, .net 1.1 and on my server is the test version of Crystal2008.
 
When using the push or pull method I'm gettig an error like this...
 
BC30201: Expression expected.
 
I think it's moaning about the REPORTSOURCE part of my CRYSTALREPORTVIEWER tag which reads "<%# \\HHdw1\wwwroot\webreport21\report1.rpt %>"
 
Any ideas folks?
With all due respect.
IP IP Logged
Matt
Newbie
Newbie
Avatar

Joined: 04 Jun 2008
Location: United Kingdom
Online Status: Offline
Posts: 19
Quote Matt Replybullet Posted: 04 Jun 2008 at 7:57am
Hold the front page!
 
Now I'm getting this error,
 
Load crpe32.dll failed
 
Once again, any advice appreciated.
With all due respect.
IP IP Logged
BrianBischof
Admin Group
Admin Group
Avatar

Joined: 09 Nov 2006
Online Status: Offline
Posts: 2458
Quote BrianBischof Replybullet Posted: 04 Jun 2008 at 8:04pm
Sounds like either a bad install or the multiple versions are corrupting each other and CR doesn't know which to use.

Are you getting the errors on your server or your dev box? Both boxes have to have the EXACT same setup. Otherwise CR will never work b/c of version issues.
Please support the forum! Tell others by linking to it on your blog or website:<a href="http://www.crystalreportsbook.com/forum/">Crystal Reports Forum</a>
IP IP Logged
Matt
Newbie
Newbie
Avatar

Joined: 04 Jun 2008
Location: United Kingdom
Online Status: Offline
Posts: 19
Quote Matt Replybullet Posted: 05 Jun 2008 at 1:23am
Thanks for that Brian, it sounds likely.
 
Regarding how 2008 was installed, we simply chose 'complete' installation so I can't imagine we could anything else, or could we?
 
On my dev box I have .net 1.1 and Crystal XI
On the server I have Crystal 2008 and .net 1.0, 1.1 and 2.0
 
What do you recommend I do regarding the installations, what shall I install where?
 
Can I not just copy CRPE32.DLL from somewhere on my machine to somewhere on the server?
 
As you can tell from these questions I'm more of a coder than an installer so any help is greatly aoppreciated.
With all due respect.
IP IP Logged
Matt
Newbie
Newbie
Avatar

Joined: 04 Jun 2008
Location: United Kingdom
Online Status: Offline
Posts: 19
Quote Matt Replybullet Posted: 05 Jun 2008 at 4:31am

Blimey! it worked.

I loaded 2008 onto a dev box to match the version on the server, knocked up an app and apart from a couple of rights type issues it all works.
 
Thanks very much for the advice.
 
I'm sure this opens a doorway on to a host of further questions but for now I'm up and running.
 
Many Thanks.
 
Matt
 
PS you beat B.O. to the solution by about 9 million years!
With all due respect.
IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.016 seconds.