Report Design
 Crystal Reports Forum : Crystal Reports for Visual Studio 2005-2015 : Report Design
Message Icon Topic: MS Vista Post Reply Post New Topic
Page  of 2 Next >>
Author Message
DreamState
Newbie
Newbie


Joined: 13 Mar 2007
Online Status: Offline
Posts: 16
Quote DreamState Replybullet Topic: MS Vista
    Posted: 23 Apr 2007 at 7:20am

Hi,

I did a search on these forums but didn't find anyone with similar issues.

I have Visual Studio 2005 and upgraded to Crystal Reports XI R2. Finally I got round to testing Vista compatability. My app runs fine. No problems at all. This was reasurring LOL. So I went to view my report and....Dead

When I first installed it and run the viewer it forced me to install a printer (instead of just defaulting to no-printer mode like it does on XP). So I installed a printer and then everytime I launched the viewer, it crashed the spooler?! Angry. Had to reset for another reason so I tried again and this time no crashing of the spooler service but this message...
 
"The request could not be submitted for background processing."
 
Another reset and spooler is crashing again and then the message above gets shown.
 
There are no clues on the web so I thought I would check in here. I know this was an issue with CR9 (according to google), but I am surprised that it is a problem with CRXI.
 
Some info that might help....
 
Its Vista Business, joined to a domain, but with manager account. Install went fine.
 
Any thoughts would be welcomed.
 
Thanks in advance,
 
Jon.


Edited by DreamState - 23 Apr 2007 at 7:23am
IP IP Logged
DreamState
Newbie
Newbie


Joined: 13 Mar 2007
Online Status: Offline
Posts: 16
Quote DreamState Replybullet Posted: 23 Apr 2007 at 12:27pm
Took some looking but found this...

http://technicalsupport.businessobjects.com/KanisaSupportSite/search.do?cmd=displayKC&docType=kc&externalId=8775223&sliceId=&dialogID=19714714&stateId=1%200%2019716977

I am not sure if I installed SP2 but my guess is nooooo as it was released in March (I upgraded sometime to XI around then so I may have missed it). I can't make out the version numbers of how they relate to the services packs. I'm on CRXI R2 11.5 so I'm guessing thats service pack 1??

Downloading now - fingers crossed this will resolve the issues.

Will let you know Smile


Edited by DreamState - 23 Apr 2007 at 12:28pm
IP IP Logged
DreamState
Newbie
Newbie


Joined: 13 Mar 2007
Online Status: Offline
Posts: 16
Quote DreamState Replybullet Posted: 24 Apr 2007 at 2:53am
Gah,
 
A long download, a longer install, but no joy for this error. When I get some time I am going to create a report from scratch and see if this helps.
 
Any thoughts on this one? Dead
 
Thanks,
 
Jon.
IP IP Logged
BrianBischof
Admin Group
Admin Group
Avatar

Joined: 09 Nov 2006
Online Status: Offline
Posts: 2458
Quote BrianBischof Replybullet Posted: 24 Apr 2007 at 10:55am
Unfortnately, I can't help. I have no plans on installing Vista until SP1 is released and even then I still might not do it. To be honest, my next computer is going to be a Mac Powerbook. Then I can boot in Windows to do application development (or run Parallels) and use the Mac for non-development computer use. 
Please support the forum! Tell others by linking to it on your blog or website:<a href="http://www.crystalreportsbook.com/forum/">Crystal Reports Forum</a>
IP IP Logged
DreamState
Newbie
Newbie


Joined: 13 Mar 2007
Online Status: Offline
Posts: 16
Quote DreamState Replybullet Posted: 25 Apr 2007 at 12:50am

Brian,

I definitely agree with you on this one. LOL. I'm gonna steer clear of it myself (may go to Linux tho and keep XP for gaming). Unfortunately I'm in a bind as the app is likely to be installed on Vista machines. I will persevere with several test reports and let you know if I have any luck.
 
Jon.
IP IP Logged
DreamState
Newbie
Newbie


Joined: 13 Mar 2007
Online Status: Offline
Posts: 16
Quote DreamState Replybullet Posted: 25 May 2007 at 11:30am
Thought I would update this as I have had some joy getting it to work.

Basically, Vista compatability is enabled with CRXI R2 Service Pack 2.

HOWEVER....

Even though I had fully upgraded and confirmed that I was indeed running CRXI R2 SP2 I still couldn't get it to function on Vista (worked fine on XP).

I was using the 'prerequisite' method in the setup project. Mucking around to day I tried the merge modules approach and found out that I prefer this method anyway (I have had trouble with Crystal Reports installing itself as a seperate application). Got excited..installed..but still not working on Vista.

So I decided on the off chance to download the latest merge modules from the Business Objects site. You know, I figured that SP2 would have updated these....but no.

Having upgraded from the existing merge modules to the downloaded ones, the app finally works perfectly on Vista.

Which is a relief.

Jon.

Smile

EDIT:

Still one slight issue, not major, but since adding the merge module I get 188 Warnings about...

'Two or more object have the same target location.' and then various file names.

I can't work out how to get rid of it. I have only added the one merge module (CrystalReports11_5_NET_2005.msm). Still builds and installs but if anyone can explain this it would be appreciated Tongue


Edited by DreamState - 25 May 2007 at 12:01pm
IP IP Logged
Dave
Newbie
Newbie


Joined: 01 Jun 2007
Location: United Kingdom
Online Status: Offline
Posts: 10
Quote Dave Replybullet Posted: 30 Jul 2007 at 12:44pm
Having read thro' this topic and looked at similar posts in the MSDN forum am I correct in thinking that the version of Crystal Reports that comes with VS 2003 (engine 9.1) or VS 2005 (engine 10.2) cannot be patched/upgraded to make it Vista compatible? 
The only way to go is to purchase CR XI R2 and then patch it with  SP 2?

I see VS 2008 is out in Beta I wonder what version of CR it will have?
Dave
Dave
IP IP Logged
BrianBischof
Admin Group
Admin Group
Avatar

Joined: 09 Nov 2006
Online Status: Offline
Posts: 2458
Quote BrianBischof Replybullet Posted: 30 Jul 2007 at 1:50pm
That would be my assumption too. I haven't confirmed it with anyone yet, but it makes sense. I haven't downloaded VS 2008 yet to see what is going on there. 
Please support the forum! Tell others by linking to it on your blog or website:<a href="http://www.crystalreportsbook.com/forum/">Crystal Reports Forum</a>
IP IP Logged
Dave
Newbie
Newbie


Joined: 01 Jun 2007
Location: United Kingdom
Online Status: Offline
Posts: 10
Quote Dave Replybullet Posted: 31 Jul 2007 at 3:38pm
Have a look at this link on MSDN

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1659055&SiteID=1

It looks like there will be a service pack to overcome the problems with the version of CR in VS 2005 and Vista.

Its due "this Spring"  and I thought it was now summer.

Dave
Dave
IP IP Logged
Dave
Newbie
Newbie


Joined: 01 Jun 2007
Location: United Kingdom
Online Status: Offline
Posts: 10
Quote Dave Replybullet Posted: 13 Nov 2007 at 5:08pm

I wonder if Virtual PC would solve this Vista issue by installing a virtual copy of XP or 2000 on the Vista machine and then installing VS 2005 to run under 2000 or XP on the Vista machine?

According to MS VS 2005 can run on Virtual PC (XP or 2000).
Confused
Dave
Dave
IP IP Logged
Page  of 2 Next >>
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.031 seconds.