Data Connectivity
 Crystal Reports Forum : Crystal Reports for Visual Studio 2005-2015 : Data Connectivity
Message Icon Topic: Decimal Values being Dropped Post Reply Post New Topic
Author Message
jlane2017
Newbie
Newbie


Joined: 17 Jul 2017
Location: United States
Online Status: Offline
Posts: 3
Quote jlane2017 Replybullet Topic: Decimal Values being Dropped
    Posted: 18 Jul 2017 at 5:34am
Need some help
When creating a new Report the Decimal Values (places) are being Dropped - Not Truncated - Just Dropped.
The Data is being extracted from a ISeries System. The connection is via a Client Access ODBC Connection (Driver) and in Crystal a connection of OLE (ADO)/Microsoft OLE DP Provider for ODBC Drivers.

The strange thing - A Report created under Crystal Reports 9 being run under Crystal 2011 - No Issues. A Report Created under Version 9 and converted to Version 2011 - No Issues. A new report created under Version 2011 - The decimal places are dropped.

Has anyone run up against this and what was the resolution?
IP IP Logged
kevlray
Moderator
Moderator
Avatar

Joined: 29 Oct 2009
Online Status: Offline
Posts: 1344
Quote kevlray Replybullet Posted: 18 Jul 2017 at 9:42am
Sounds like a view issue.  I do not remember what the default decimal settings are for CR 2011.  We are on CR 2013 and have been for a while.
IP IP Logged
jlane2017
Newbie
Newbie


Joined: 17 Jul 2017
Location: United States
Online Status: Offline
Posts: 3
Quote jlane2017 Replybullet Posted: 19 Jul 2017 at 4:18am
Thanks for the information. I did try several different variations of settings within VIEWS and the ODBC Connection with no luck before post my Issue on the FORUM.

I think I may have resolved my Issue by creating a new type of connection within Crystal
Under OLEDB (ADO) - Select - IBM DB2 for i IBMDASQL OLE DB Provider. There is a downside though - There is no presentation of Files to Choose from. A SQL Query needs to be created in order to see the selection of fields.
IP IP Logged
kevlray
Moderator
Moderator
Avatar

Joined: 29 Oct 2009
Online Status: Offline
Posts: 1344
Quote kevlray Replybullet Posted: 19 Jul 2017 at 12:11pm
Okay, definitely looks like a database connection issue. I do not know if current ODBC driver for IBM DB2 works well with Crystal or not.  We prefer to a command for most of our reports.  Puts most of the processing on the server and we can be more creative in bringing in data.
IP IP Logged
jlane2017
Newbie
Newbie


Joined: 17 Jul 2017
Location: United States
Online Status: Offline
Posts: 3
Quote jlane2017 Replybullet Posted: 25 Jul 2017 at 3:15am
Thanks again for the assist.
I also find it easier to build a SQL Query and testing it on the iSeries System - Then doing a copy/Paste into Crystal.
IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.063 seconds.